Resolvendo problema de zlib na instalação do Rails com RVM

Tentando instalar o rails utilizando o comando “gem install rails –pre” recebia sempre o erro:

ERROR:  Loading command: install (LoadError)
no such file to load — zlib
ERROR:  While executing gem … (NameError)
uninitialized constant Gem::Commands::InstallCommand

Para solucioná-lo, basta seguir as seguintes etapas:

rvm package install zlib
rvm remove 1.8.7 (no caso, a versão do seu Rails)
rvm install 1.8.7 (sim, a mesma que fora removida)

Pronto, agora ele será recompilado com a zlib.

Simples!

About these ads

3 Comments

  1. Leandro
    Posted setembro 23, 2010 at 12:06 am | Permalink | Resposta

    Estou com este problema e nao consegui resolver dessa forma. Já removi e instalei o zlib, mas nada de funcionar. =(

  2. Tiago Deliberali
    Posted dezembro 26, 2010 at 11:27 pm | Permalink | Resposta

    Cara, deu certo!

    To usando o Ubuntu 10.10 e tava tendo problema com o rvm + ruby 1.9.2

    Valeu!!

  3. Natanael Pantoja
    Posted março 31, 2012 at 3:26 pm | Permalink | Resposta

    E ai gogs..

    O problema é que essa solução não rola mais..não funciona mais. Sabe outra solução?

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

Seguir

Obtenha todo post novo entregue na sua caixa de entrada.

%d blogueiros gostam disto: